Reinstalling Debian woes

This is a geeky post which is unlikely to be interesting or even understandable to anyone other than those familiar with Debian Linux or similar systems.

I managed to trash my Debian system just recently. The /root partition was too small. I used gparted to increase it but made the mistake of gparted’ing the / EFI partition while increasing the size of the /root partition. My Debian system has been great for years and I’m out of practice installing Linux. My excuse – as poor as it is – is that / is traditionally the root partition. The Linux filesystem has changed and now there’s a /root partition and / is the /boot partition.

I tried to the repair the / EFI partition without success. The reEFI tools wouldn’t work for me. I reinstalled Debian many times while keeping my /home partition. I was using Debian install in expert mode.

I found that xfce4 was virtually useless after the Debian install. I suppose that it may be because I’m keeping my /home partition upsetting the settings. [2/11/16 I’ll try getting rid of anything relevant. [2/11 later. It was the previous config messing it up))  All applications are obscuring the start menu and the minimise, maximise, close window **adornments** are missing. Audio is simply not working after a Debian 8 install – what’s that about? It should just work, I tried fixing it but I shouldn’t have to. Debian used to install so well. It’s a 2011 A64 system [2/11/16 Amd64) , mainstream now and really should be no problem.

Years ago (95-05) gnome was fine if a bit heavy and slow. I can’t stand it now even in classic mode. The default gnome is unbearable. KDE is so slow and a real pain to achieve anything. Audio still not working. [2/11/16  soundcard not recognised appears to be a problem with Deb8 install. I tried to get hold of Deb7 install because it upgrades fine … )

[ed: After reinstalling Debian on one occasion apt was warning that installations were unverified. apt’s verification system was compromised.)

I then tried to netinstall Debian. I suppose this is the real reason of this post. Fetching a netinstall image from Debian.org I noticed that I was downloading from another not Debian.org site. I do anyway check integrity and the netinstall image sha256sum was wrong. I found it difficult to find the sha256sum on the Debian site which was a bit of a pain.

[ed: Were the spooks onto me?)

I’m likely to install OpenBSD as a desktop.

Simple security suggestions: Check integrity of install images, use long passwords, use a firewall, check what services are visible using nmap.

[4/11/16 Looks like audio was fine and not working due to a silly mistake by me.]

This entry was posted in geeky tech and tagged , , , . Bookmark the permalink.

Leave a Reply

Your email address will not be published.